It’s been a long time

First and foremost, I do apologize for how long its taken to get things started again. The site had a lot of traffic when we first kicked off on December 24, 2009. Things were going great but unfortunately traffic slowed down and detoured to our Facebook page.

Because so much effort had gone into the actual website/forum, I had decided to limit posting on the Facebook page in 2012. It also didnt help that at the time I was medboarding from the Army, going through a divorce, trying to find a job in Germany and then stateside. With a full plate I stepped back from everything, and life just kept happening.

Around December 2014, the site went down. Everything we had on our forums was lost, including and very regrettably, the pictures from all the events and hangouts we had done. At this time the website fully transferred ownership from the previous and very much behind the scenes owner to myself. I had intended to restore the forums, considering I had (and still have) back-ups.

I find myself now sick of leaving projects half started or dead, so I decided to revive the site, properly. Unfortunately the forums do not function with our current website software. If the forums are to return, I need to know that there is in an interest in it, and I will try to find a way to do that.

In the meantime, I am currently living in Keller, Texas, and I would like to begin showcasing rides and events on this website, and find a way to have it utilized for its original purpose, to serve the overseas and stateside military car communities. I am hoping that the site will once again have high traffic. In the meantime, stay tuned for more updates. Thanks for checking in.

Rick

Leave a Reply

Your email address will not be published.